Rerouting of US region redirects to EU region

Incident Report for Short.io

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 06:29 UTC

Monitoring

AWS Global Accelerator rerouted all redirects to EU and Australia regions. All links work, but a bit slower (extra 500ms latency)
Posted Oct 20, 2025 - 16:14 UTC
This incident affected: URL redirector.